AviaSkins.Forums

AviaSkins.Forums (http://forum.aviaskins.com/index.php)
-   "Солянка сборная". (http://forum.aviaskins.com/forumdisplay.php?f=39)
-   -   DGen PACK: обновления/обсуждение (http://forum.aviaskins.com/showthread.php?t=4386)

Asura 08.04.2016 21:38

DGen PACK: обновления/обсуждение
 

Авторская сборка «модов» для игры IL-2 Sturmovik 1946 v.4.13.3. В первую очередь сборка предлагается как основа для создания и прохождения статических и динамических кампаний с использованием «модных» карт, объектов, техники и самолетов.

При создании сборки использованы материалы:

► сайтов:► паков:
  • DBW 1.71
  • HSFX 7.0.3

Основные (базовые) «моды» используемые в сборке:
  • SAS Modact 6.1 for IL-2 4.13.1m – доработан для совместимости с некоторыми «модами»;
  • SAS Common Utils 1.09;
  • SAS Engine Mod v.2.8.1 – доработан для совместимости с игрой версии 4.13.3;
  • Minimap by SAS~benitomuso – доработан для совместимости с игрой версии 4.13.3;
  • HD Texture DLLs by carsmaster;
  • True Color Texture Mod by SAS~Storebror;
  • Command and Control v. 3.031 by SAS~Checkyersix – доработан для совместимости с игрой версии 4.13.3;
  • IL-2 1956 - "The Jet Era" – доработан для совместимости с игрой версии 4.13.3.
При упаковке SFS и использована программа Total MODder V3 by benitomuso (PAL).

Материал собирался несколько лет и, к сожалению, авторство некоторых «модов» восстановить не получилось, поэтому авторство остальных «модов» сознательно не указывается.

В процессе работы все «моды» были адаптированы для игры версии 4.13.3. По возможности русифицированы сообщения «зашитые» в классы.

Сборка полностью свободна от любых ограничений на распространение и использование как целиком, так и по частям, распространяется «как есть». При этом не предусматривается никаких гарантий, явных или подразумеваемых.

В сборку можно устанавливать любые дополнительные «моды», способ установки аналогичен добавлению «модов» в SAS Modact, однако стабильная работа в этом случае не гарантируется из-за отсутствия
совместимости между разными «модами» и игрой версии 4.13.3.

В сборку включены авторские динамические кампании от Motorhead'а (Обновление пакета динамических кампаний для DGen PACK 2.0).

Ссылки на скачивание и краткое описание DGen PACK'а содержатся в инструкции по установке и использованию:

https://lh3.googleusercontent.com/ge...2=w256-h220-no.

Порядок УСТАНОВКИ DGen PACK 2.0:
Цитата:

Сообщение от Asura (Сообщение 162591)

Установка на DGen PACK 1.3:
  1. Установить обновление 4.13.3
  2. Удалить каталоги !AircraftSelector, #DGEN, DGen
  3. Загрузить обновление DGenPACK 2.0
  4. Установить обновление и согласится с заменами (запустить DGenPack_2_0.exe)
  5. При необходимости установить патч для международной версии DGenPack_2_0_INT.exe
Установка на "чистую" игру версии 4.13.3:
  1. Загрузить обновление DGenPACK 1.3
  2. Запустить DGenPack_1_3.part01.exe и установить сборку
  3. Удалить каталоги !AircraftSelector, #DGEN, DGen
  4. Загрузить обновление DGenPACK 2.0
  5. Установить обновление и согласится с заменами (запустить DGenPack_2_0.exe)
  6. При необходимости установить патч для международной версии DGenPack_2_0_INT.exe
Для скачивания новой версии с rutracker.org:
  1. Переименовать каталог DGenPACK_1_3 в DGenPACK
  2. Открыть вложенный файл в своем торрент-клиенте
  3. После проверки торрента будут загружены два файла: DGenPack_2_0.exe и DGenPack_2_0_INT.exe (остальные файлы от версии 1.3 загружаться не будут, они не менялись)

ВАЖНОЕ замечание:

После установки необходимо зайти в каталог игры, и, если в нем обнаружится файл DGen_mod.ini, его необходимо переименовать в DGenMOD.ini.

Источники для загрузки DGen PACK:
(DGen PACK версии 1.3 и обновление до версии 2.0)

https://lh3.googleusercontent.com/-m...ud_mail_ru.png
https://lh3.googleusercontent.com/5C...ma=w226-h55-no

Альтернативные источники для загрузки DGen PACK:
(DGen PACK версии 1.3 и обновление до версии 2.0)

https://lh3.googleusercontent.com/OB...S=w300-h101-no

Обновление DGen PACK до версии 2.0.1:
Цитата:

Сообщение от Asura (Сообщение 165385)

Небольшое обновление для полной совместимости с патчем 4.13.4; в качестве бонуса обновления и добавление динамических кампаний от Motorhead.

Установка на DGen PACK 2.0:
  1. Установить обновление 4.13.4.
  2. Удалить каталог DGen (или переименовать).
  3. Загрузить обновление DGen PACK 2.0.1 (ссылка для загрузки ниже).
  4. Установить обновление в папку с DGen PACK 2.0 (запустить DGenPack_2_0_1.exe и согласится с заменами).

Цитата:

Сообщение от Motorhead (Сообщение 165388)

В обновлении 2.0.1 добавлено много новых кампаний, фактически, вся папка DGen обновилась. Все о чем я писал в апдейтах в "дневниках разработки" вошло в это обновление. Более подробная инфа по обновлению кампаний в файлике "2.0.1 readme RU", который появится в корневом каталоге DGen PACK'а после установки обновления 2.0.1.

https://lh3.googleusercontent.com/wF...Ik=w226-h56-no


Обсуждение кампании "ПВО Москвы" (в девичестве "Битва за Москву"),
включённой в DGen PACK:


https://lh3.googleusercontent.com/-y..._Moscow_70.png
Цитата:

Сообщение от Motorhead (Сообщение 152697)

Сразу же ВАЖНОЕ ПРИМЕЧАНИЕ для тех, кто будет проходить динамическую кампанию "Битва за Москву". Я очень рекомендую в файлике DGenMOD.ini установить параметр GroundIntensity (он влияет на количество наземных объектов в миссиях) на значение:

GroundIntensity=Medium
или даже
GroundIntensity=Low


Наземки в кампании ОЧЕНЬ много, и режим GroundIntensity=High будет вызывать сильные тормоза даже на самых мощных машинах. GroundIntensity=High можно будет использовать в будущем, в моих новых кампаниях, которые будут использовать не такие большие по размеру карты как "Москва" Окневаса.


Motorhead 08.04.2016 22:07

Режь последний огурец :)
Ну, будем считать общественный бета-тест начался. Всем кто ждет "Битву за Москву" - она разработана специально для этой сборки, будет в релизе.

Vasya 08.04.2016 22:29

Цитата:

Сообщение от Asura
Выход сборки планируем через недельку где то, устанавливается на чистый 4.13.1, дополнительно ничего ставить не надо.
Цитата:

Сообщение от UFO (Сообщение 151265)
+100500:bravo:

Хочу, очень хочу.
Вопросс проффесиональный - диффим будет поддерживать фм в двух кодировках или только одной.

Asura 08.04.2016 22:35

диффм стандартный из САС МодАкт, все ФМ из сборки перепакованы в свой батоннз, батонз доступен, есть в распакованном состоянии. :) выше уже ссылки на сборку -можно качать - смотреть. :)

Vasya 08.04.2016 22:45

Цитата:

Сообщение от Asura (Сообщение 151289)
диффм стандартный из САС МодАкт, все ФМ из сборки перепакованы в свой батоннз, батонз доступен, есть в распакованном состоянии. :) выше уже ссылки на сборку -можно качать - смотреть. :)

Спасибо большое!
Уточните пожалуйста диффим из какого модакта брать?
Помню что у меня с Модактом 6.01 читать фм с девяточниым кодом не желала - перепаковывал все отдельные фм десяточным.
И ещё - допустим я сейчас не могу поставить всю вашу сборку - банально нет места, освобожу место только на следующей неделе, а новый патч хочеться поставить. Но нужно: модификатор, диффим под моды, ваш новый баттонз - это минимум.
В общем вопрос выглядит так: что нужно(где взять не качая большой объём) минимально поставить к новому патчу что бы он мог принимать моды?
Благодарю зарание за пояснение!!!
Перехожу окончательно на новый патч, поэтому всё старое удалю, а свои модики перепилю под самый новый в его среде.

злой 09.04.2016 03:54

Цитата:

Сообщение от Asura (Сообщение 151276)
Да я это как раз понимаю, потому и взялся сделать для себя сборку сразу с учетом многих ошибок и своих и чужих. Это уже по прошествии полугодовой работы сборка "для себя" трансформировалась в сборку для генератора. Изначально вообще делал под 4.13RC4. А так как переход на новые версии запланировал изначально - перевод сборки на 4.13.1 занял пару дней.
Вопрос - а что такого осталось в 4.09? Может я чего упустил?



Ну тут я выбрал радикальный путь - я все основные моды сам переделал под новую версию.

а как быть тем, кто не умеют делать сборки? я вот , просил дать ссылки на нормальную сборку для 4.13. ответ молчание. последний раз спрашивал за Ил-28, результат тот же.
скачал тут сборку сам, она весила со всеми зипами 7 гигов, но как оказалось, что для нее нужны еще какие то сборки. поэтому все снес и забыл.

злой 09.04.2016 04:00

Цитата:

Сообщение от Asura (Сообщение 151260)

Когда начну добавлять WWI хотел к тебе обратиться за помощью как раз по перечню самолетов и само собой за скинами. Очень хочу добавить в сборку отдельные классы для техники WWI. С ней как то вообще туго.

здесь я готов помочь, мы же уже это начинали делать. я сделал папки по странам и наградам. но вот с картами помочь не могу.

Asura 09.04.2016 07:01

Цитата:

Сообщение от злой (Сообщение 151299)
а как быть тем, кто не умеют делать сборки? я вот , просил дать ссылки на нормальную сборку для 4.13. ответ молчание. последний раз спрашивал за Ил-28, результат тот же.
скачал тут сборку сам, она весила со всеми зипами 7 гигов, но как оказалось, что для нее нужны еще какие то сборки. поэтому все снес и забыл.

А просто не было сборок под 4.13, никто не делал. Собственно после обсуждений с Моторхедом ситуации с модами, то что пользователям сложно что то добавлять, я и перепрофелировал свою сборку на публичную. Попробуй, вдруг подойдет. :)
Ил-28 под сборку я уже переделал, будет в следующем дополнении, но могу выложить и отдельно.
Сборка DGen_PACK устанавливается сразу на чистый 4.13.1. Дополнительно ничего не надо - ни активатора, ни диффм, ничего.
Вася - прочти это :) дополнительно ничего качать и ставить не надо, все в комплекте.

Asura 09.04.2016 07:03

Цитата:

Сообщение от злой (Сообщение 151300)
здесь я готов помочь, мы же уже это начинали делать. я сделал папки по странам и наградам. но вот с картами помочь не могу.

Отлично, спасибо. Как доделаю реактивов начну спрашивать. Все карты по wwlкоторые нашел уже добавлены.

злой 09.04.2016 07:22

Цитата:

Сообщение от Asura (Сообщение 151302)
А просто не было сборок под 4.13, никто не делал. Собственно после обсуждений с Моторхедом ситуации с модами, то что пользователям сложно что то добавлять, я и перепрофелировал свою сборку на публичную. Попробуй, вдруг подойдет. :)
Ил-28 под сборку я уже переделал, будет в следующем дополнении, но могу выложить и отдельно.
Сборка DGen_PACK устанавливается сразу на чистый 4.13.1. Дополнительно ничего не надо - ни активатора, ни диффм, ничего.
Вася - прочти это :) дополнительно ничего качать и ставить не надо, все в комплекте.

спасибо, ппока проблема с местом на дисках. надо ил 4.10 сность.

deSAD 09.04.2016 09:41

Цитата:

Сообщение от Asura (Сообщение 151281)
... Это не релиз, пока просто посмотреть-попробовать.

И, тем не менее (или даже тем более ;)) ...

Цитата:

Сообщение от Asura (Сообщение 151281)
Все интересующие моды которых нет ставить в папку #DGEN.

А вот небольшой рид.ми (хотя бы с перечнем тех МОДов, которых есть), все же не помешал бы ... я так думаю © :ups: Да и про структуру/назначение папок хотелось бы узнать :rtfm: Положим, STD или XTD загадки не представляют, а вот для чего YTD? Или _SYNCAPP? :I'm_thinking: Тем более что последняя папочка - надо полагать - (немало)важная, если судить по "поднятому" атрибуту "Скрытый" :rolleyes:

З.Ы.
В PaintSchemes\Skins, полагаю, присутствуют папочки только лишь для МОДных крафтов?

deSAD 09.04.2016 14:18

Цитата:

Сообщение от Asura (Сообщение 151281)
... Это не релиз, пока просто посмотреть-попробовать.

Получилось © :ok:


Парочка запытаннячок, если позволишь, дядя Дима ...
  1. Почему в сборке, которая - судя по всему (в т. ч. и по названию ;)) - ориентирована на (активное) использование "МОДного" DGen'а, данный компонент отсутствует в принципе? :eek:
  2. Почему используется "старый" селектор, версии 3.1.2 (если судить по "шапке" и 3.1.3, если заглянуть на вкладку "Подробно" в свойствах), а не крайняя версия, 3.1.4? :I'm_thinking: Тому есть какие-то определенные причины?
  3. Что это за SAS Engine Mod 2.8? Я что-то пропустил? :ups:

Позволь еще раз поблагодарить за твои труды на благо ИЛа и (со)общества, дядя Дима ...

Grog 09.04.2016 15:22

Цитата:

Сообщение от deSAD (Сообщение 151315)

Насколько понимаю, заставка? Или???:rolleyes::rolleyes::rolleyes:
Эмм...:ups: В игре, насколько помню, такой травки ещё не было??:)

YurBorR 09.04.2016 15:38

Цитата:

Сообщение от Asura (Сообщение 151281)
...Содержимое архивов распаковать в папку с чистым 4.13.1. Больше ничего не нужно...

Вот с этим маленькие непонятки. У меня с чистым илом и дгенпаком не запустилась динкампания, посмотрел, всё понятно: добавил Дген 2041 с DGen_mod.ini, потом дген запросил папку "Мод" с AllWeapons и уже всё запустилось. Может я что-то не так понял, сделал, поэтому пожалуйста напишите, как и что делать, да и deSAD уже спросил про "небольшой рид.ми".
И официальная часть.
Уважаемый Asura!
Огромнейшее вам спасибо за ДгенПак: посмотрел новую карту Москвы, другие модовые самолёты и всё на русском, всё разложено по полочкам. И я чертовски доволен, что у меня наконец-то такая рабочая сборка и кстати, других уже нет.

Motorhead 09.04.2016 15:47

Цитата:

Сообщение от deSAD (Сообщение 151315)
[*]Почему в сборке, которая - судя по всему (в т. ч. и по названию ;)) - ориентирована на (активное) использование "МОДного" DGen'а, данный компонент отсутствует в принципе? :eek:

Упущение, данный компонент видимо забыли, как говорит Самурай присунуть:)
Вот первый РЦ "Битвы за Москву"
http://www.mediafire.com/download/41...09.04.2016.rar
Папку ДГЕН из архива размещаем в корневик сборки, туда же сам экзешник ДГЕНа, и DGen_mod.ini. После этого в меню появятся кампании за ВВС РККА и Люфтваффе.

YurBorR 09.04.2016 16:06

Цитата:

Сообщение от Motorhead (Сообщение 151322)
...Вот первый РЦ "Битвы за Москву"...

Сразу поставил и сразу вопрос: не заходит в "Вооружение-Настройка" самолёта. Это так задумано или у меня...? Общий Дген заминусовал, Дген только "Битва за москву".

Motorhead 09.04.2016 16:20

Кампания за кого, какая операция и какой выбран сквад при старте?

злой 09.04.2016 16:46

чую буду долго качать сборку. самое обидное, был сбой с винтом. комп перестал его видеть при копировании шкур и модов, половина или больше теперь потерена((

deSAD 09.04.2016 18:00

Цитата:

Сообщение от Motorhead (Сообщение 151322)
Цитата:

Сообщение от deSAD (Сообщение 151315)
Почему в сборке, которая - судя по всему (в т. ч. и по названию ;)) - ориентирована на (активное) использование "МОДного" DGen'а, данный компонент отсутствует в принципе? :eek:

Упущение, данный компонент видимо забыли, как говорит Самурай присунуть :)

Гы :D Это случается © :rolleyes:
Цитата:

Сообщение от Motorhead (Сообщение 151322)
Вот первый РЦ "Битвы за Москву"
http://www.mediafire.com/download/41...09.04.2016.rar
Папку ДГЕН из архива размещаем в корневик сборки, туда же сам экзешник ДГЕНа, и DGen_mod.ini. После этого в меню появятся кампании за ВВС РККА и Люфтваффе.

Дякую :thx:
Цитата:

Сообщение от злой (Сообщение 151326)
чую буду долго качать сборку.

Чегой-то? Диск G00GLE довольно шустро файлы отдает :ok:
Цитата:

Сообщение от злой (Сообщение 151326)
самое обидное, был сбой с винтом. комп перестал его видеть при копировании шкур и модов, половина или больше теперь потерена((

Упс :eek: Вот это - действительно - печально :cry:

deSAD 09.04.2016 18:30

@ Asura
Еще малость вопросиков :ups:
  1. Jet Era не включена в сборку по каким-то "принципиальным" соображениям или пока не включена, поскольку "это не релиз, пока просто посмотреть-попробовать"?
  2. Тот же вопрос в отношении т. н. "Forgotten Countries".
  3. Что явилось "первоисточником" для МОДных "фок", включенных в сборку? Не похоже, что это был небезызвестный Claymore's Pack :ups:
  4. Очевидно, что двумя звездочками - "**" - помечены "МОДные" объекты, а вот что обозначает одна - "*"?


Текущее время: 08:15. Часовой пояс GMT +3.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd. Перевод: zCarot